// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:.+V)([0-9.]+)(?:.+|$)").unwrap();
let string = "A12 V1.1
A9 V2.3 8.99
A34 8.3 V4";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}