package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:.+V)([0-9.]+)(?:.+|$)`)
var str = `A12 V1.1
A9 V2.3 8.99
A34 8.3 V4`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}