re = /(?:.+V)([0-9.]+)(?:.+|$)/m
str = 'A12 V1.1
A9 V2.3 8.99
A34 8.3 V4'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result