use strict;
my $str = 'A12 V1.1
A9 V2.3 8.99
A34 8.3 V4';
my $regex = qr/(?:.+V)([0-9.]+)(?:.+|$)/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";