#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\.\w+)\1+$"
Local $sString = "myoutput.pdf" & @CRLF & _
"hello.pdf.pdf" & @CRLF & _
"byebye.txt" & @CRLF & _
"hey.txt.txt"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)