$re = '/(\.\w+)\1+$/m';
$str = 'myoutput.pdf
hello.pdf.pdf
byebye.txt
hey.txt.txt';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;