re = /(\.\w+)\1+$/m
str = 'myoutput.pdf
hello.pdf.pdf
byebye.txt
hey.txt.txt'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result