using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\.\w+)\1+$";
string substitution = @"$1";
string input = @"myoutput.pdf
hello.pdf.pdf
byebye.txt
hey.txt.txt";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}