#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\bhas\b\W*"
Local $sString = "user hashimoto has two dogs"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)