import re
regex = re.compile(r"\bhas\b\W*")
test_str = "user hashimoto has two dogs"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)