$re = '/\bhas\b\W*/';
$str = 'user hashimoto has two dogs';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;