using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bhas\b\W*";
string substitution = @"";
string input = @"user hashimoto has two dogs";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}