use strict;
my $str = 'user hashimoto has two dogs';
my $regex = qr/\bhas\b\W*/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";