# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\d{2}) (\d{4}) - (.*?)\.mp4/ $2-$1 - $3.mp4 /gm;t' <<< "04 2020 - Refresher Series.mp4"