package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d{2}) (\d{4}) - (.*?)\.mp4`)
var str = `04 2020 - Refresher Series.mp4`
var substitution = " $2-$1 - $3.mp4 "
fmt.Println(re.ReplaceAllString(str, substitution))
}