const regex = /(\d{2}) (\d{4}) - (.*?)\.mp4/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{2}) (\\d{4}) - (.*?)\\.mp4', 'gm')
const str = `04 2020 - Refresher Series.mp4`;
const subst = ` $2-$1 - $3.mp4 `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);