$re = '/(\d{2}) (\d{4}) - (.*?)\.mp4/m';
$str = '04 2020 - Refresher Series.mp4';
$subst = " $2-$1 - $3.mp4 ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;