#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\d{2}) (\d{4}) - (.*?)\.mp4"
Local $sString = "04 2020 - Refresher Series.mp4"
Local $sSubst = " $2-$1 - $3.mp4 "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)