re = /(\d{2}) (\d{4}) - (.*?)\.mp4/m
str = '04 2020 - Refresher Series.mp4'
subst = ' $2-$1 - $3.mp4 '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result