#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)asd-[0-9][a-z]-([0-9]{4})([0-9]{2})([0-9]{2})"
Local $sString = "bsd-3A-20170523" & @CRLF & _
"asd-3A-20170523" & @CRLF & _
"NotTheDroidsYourLookingFor-20171131" & @CRLF & _
"asd-1D-20170523" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")