import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "asd-[0-9][a-z]-([0-9]{4})([0-9]{2})([0-9]{2})";
final String string = "bsd-3A-20170523\n"
+ "asd-3A-20170523\n"
+ "NotTheDroidsYourLookingFor-20171131\n"
+ "asd-1D-20170523\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}