re = /asd-[0-9][a-z]-([0-9]{4})([0-9]{2})([0-9]{2})/i
str = 'bsd-3A-20170523
asd-3A-20170523
NotTheDroidsYourLookingFor-20171131
asd-1D-20170523
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end