# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"asd-[0-9][a-z]-([0-9]{4})([0-9]{2})([0-9]{2})"
test_str = ("bsd-3A-20170523\n"
"asd-3A-20170523\n"
"NotTheDroidsYourLookingFor-20171131\n"
"asd-1D-20170523\n")
matches = re.finditer(regex, test_str, re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.