using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"asd-[0-9][a-z]-([0-9]{4})([0-9]{2})([0-9]{2})";
string input = @"bsd-3A-20170523
asd-3A-20170523
NotTheDroidsYourLookingFor-20171131
asd-1D-20170523
";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}