package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)asd-[0-9][a-z]-([0-9]{4})([0-9]{2})([0-9]{2})`)
var str = `bsd-3A-20170523
asd-3A-20170523
NotTheDroidsYourLookingFor-20171131
asd-1D-20170523
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}