#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[1-9]\d*(?[\,\.]\d{3})?$"
Local $sString = "3434.34534..45435.3454" & @CRLF & _
"2323.23" & @CRLF & _
"10.34" & @CRLF & _
"10.." & @CRLF & _
"2123.23.232" & @CRLF & _
"23432432" & @CRLF & _
"23432frerw33243" & @CRLF & _
"00076785.75675" & @CRLF & _
"fsf3454dfgdfg" & @CRLF & _
"fdgd43545.34543" & @CRLF & _
"435435.435.345" & @CRLF & _
"1000000" & @CRLF & _
"1.77676767676" & @CRLF & _
"145435.534545" & @CRLF & _
"34.43" & @CRLF & _
"3545.34545" & @CRLF & _
"4324324324.324324324324dgdg" & @CRLF & _
"324342" & @CRLF & _
"2343.2343" & @CRLF & _
"32224323." & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")