using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[1-9]\d*(?[\,\.]\d{3})?$";
string input = @"3434.34534..45435.3454
2323.23
10.34
10..
2123.23.232
23432432
23432frerw33243
00076785.75675
fsf3454dfgdfg
fdgd43545.34543
435435.435.345
1000000
1.77676767676
145435.534545
34.43
3545.34545
4324324324.324324324324dgdg
324342
2343.2343
32224323.
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}