import Foundation
let pattern = #"^[1-9]\d*(?[\,\.]\d{3})?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
3434.34534..45435.3454
2323.23
10.34
10..
2123.23.232
23432432
23432frerw33243
00076785.75675
fsf3454dfgdfg
fdgd43545.34543
435435.435.345
1000000
1.77676767676
145435.534545
34.43
3545.34545
4324324324.324324324324dgdg
324342
2343.2343
32224323.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)