use strict;
my $str = '3434.34534..45435.3454
2323.23
10.34
10..
2123.23.232
23432432
23432frerw33243
00076785.75675
fsf3454dfgdfg
fdgd43545.34543
435435.435.345
1000000
1.77676767676
145435.534545
34.43
3545.34545
4324324324.324324324324dgdg
324342
2343.2343
32224323.
';
my $regex = qr/^[1-9]\d*(?[\,\.]\d{3})?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}