const regex = new RegExp('^[1-9]\\d*(?[\\,\\.]\\d{3})?$', 'gm')
const str = `3434.34534..45435.3454
2323.23
10.34
10..
2123.23.232
23432432
23432frerw33243
00076785.75675
fsf3454dfgdfg
fdgd43545.34543
435435.435.345
1000000
1.77676767676
145435.534545
34.43
3545.34545
4324324324.324324324324dgdg
324342
2343.2343
32224323.
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}