#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=Invoice number: |Invoice Number: |Invoice no: |InvoiceNumber: )\d{6}"
Local $sString = "Invoice number: 123456" & @CRLF & _
"" & @CRLF & _
"Invoice Number: 123456" & @CRLF & _
"" & @CRLF & _
"Invoice no: 123456" & @CRLF & _
"" & @CRLF & _
"InvoiceNumber: 123456"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")