const regex = /(?<=Invoice number: |Invoice Number: |Invoice no: |InvoiceNumber: )\d{6}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=Invoice number: |Invoice Number: |Invoice no: |InvoiceNumber: )\\d{6}', 'gm')
const str = `Invoice number: 123456
Invoice Number: 123456
Invoice no: 123456
InvoiceNumber: 123456`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}