re = /(?<=Invoice number: |Invoice Number: |Invoice no: |InvoiceNumber: )\d{6}/m
str = 'Invoice number: 123456
Invoice Number: 123456
Invoice no: 123456
InvoiceNumber: 123456'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end