import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=Invoice number: |Invoice Number: |Invoice no: |InvoiceNumber: )\\d{6}";
final String string = "Invoice number: 123456\n\n"
+ "Invoice Number: 123456\n\n"
+ "Invoice no: 123456\n\n"
+ "InvoiceNumber: 123456";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}