using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=Invoice number: |Invoice Number: |Invoice no: |InvoiceNumber: )\d{6}";
string input = @"Invoice number: 123456
Invoice Number: 123456
Invoice no: 123456
InvoiceNumber: 123456";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}