import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\((.*)\\)";
final String string = "<li><a href=\"/wiki/%C3%81_Bao_A_Qu\" title=\"Á Bao A Qu\">Á Bao A Qu</a> (<a class=\"mw-redirect\" href=\"/wiki/Malay_(ethnic_group)\" title=\"Malay (ethnic group)\">Malay</a>) – Entity that lives in the <a href=\"/wiki/Vijaya_Stambha\" title=\"Vijaya Stambha\">Tower of Victory in Chitor.</a></li>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}