import re
regex = re.compile(r"\((.*)\)", flags=re.MULTILINE)
test_str = "<li><a href=\"/wiki/%C3%81_Bao_A_Qu\" title=\"Á Bao A Qu\">Á Bao A Qu</a> (<a class=\"mw-redirect\" href=\"/wiki/Malay_(ethnic_group)\" title=\"Malay (ethnic group)\">Malay</a>) – Entity that lives in the <a href=\"/wiki/Vijaya_Stambha\" title=\"Vijaya Stambha\">Tower of Victory in Chitor.</a></li>"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")