const regex = /\((.*)\)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\((.*)\\)', 'gm')
const str = `<li><a href="/wiki/%C3%81_Bao_A_Qu" title="Á Bao A Qu">Á Bao A Qu</a> (<a class="mw-redirect" href="/wiki/Malay_(ethnic_group)" title="Malay (ethnic group)">Malay</a>) – Entity that lives in the <a href="/wiki/Vijaya_Stambha" title="Vijaya Stambha">Tower of Victory in Chitor.</a></li>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}