#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\btext\.\w+\([^()]*\n> \)"
Local $sString = "blah" & @CRLF & _
"blah blah blah" & @CRLF & _
"text.get(" & @CRLF & _
"'hi'" & @CRLF & _
"'you're" & @CRLF & _
"'welcome'" & @CRLF & _
")" & @CRLF & _
"text.get(" & @CRLF & _
"'hi'" & @CRLF & _
"'i'm'" & @CRLF & _
"'here'" & @CRLF & _
"> )" & @CRLF & _
" blah blah blah"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")