const regex = /\btext\.\w+\([^()]*\n> \)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\btext\\.\\w+\\([^()]*\\n> \\)', 'g')
const str = `blah
blah blah blah
text.get(
'hi'
'you're
'welcome'
)
text.get(
'hi'
'i'm'
'here'
> )
blah blah blah`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}