package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\btext\.\w+\([^()]*\n> \)`)
var str = `blah
blah blah blah
text.get(
'hi'
'you're
'welcome'
)
text.get(
'hi'
'i'm'
'here'
> )
blah blah blah`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}