using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\btext\.\w+\([^()]*\n> \)";
string input = @"blah
blah blah blah
text.get(
'hi'
'you're
'welcome'
)
text.get(
'hi'
'i'm'
'here'
> )
blah blah blah";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}