using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!src="")http:\/\/[\w.-]*";
string input = @"border=""0"" src=""http://www.stackoverflow.com
123 http://abc123.com asg
123 http://uvw-avc_132.be abc";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}