import re
regex = re.compile(r"(?<!src=\")http:\/\/[\w.-]*", flags=re.MULTILINE)
test_str = ("border=\"0\" src=\"http://www.stackoverflow.com \n"
"123 http://abc123.com asg\n"
"123 http://uvw-avc_132.be abc")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")