const regex = /(?<!src=")http:\/\/[\w.-]*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!src=")http:\\\/\\\/[\\w.-]*', 'gm')
const str = `border="0" src="http://www.stackoverflow.com
123 http://abc123.com asg
123 http://uvw-avc_132.be abc`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}