import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!src=\")http:\\/\\/[\\w.-]*";
final String string = "border=\"0\" src=\"http://www.stackoverflow.com \n"
+ "123 http://abc123.com asg\n"
+ "123 http://uvw-avc_132.be abc";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}