re = /(?<!src=")http:\/\/[\w.-]*/m
str = 'border="0" src="http://www.stackoverflow.com
123 http://abc123.com asg
123 http://uvw-avc_132.be abc'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end