$re = '/(?<!src=")http:\/\/[\w.-]*/m';
$str = 'border="0" src="http://www.stackoverflow.com
123 http://abc123.com asg
123 http://uvw-avc_132.be abc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);