#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "{[^}]*}"
Local $sString = "{fefeef}this{feofeow}.4849"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)