$re = '/{[^}]*}/';
$str = '{fefeef}this{feofeow}.4849';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;